Back to overview
Degraded

Unplanned 4G service outage in localised area.

Aug 25 at 11:12am AEST
Affected services
Network Stability

Updated
Aug 26 at 03:22pm AEST

We are continuing to experience a significant local network outage affecting 4G in the following localities: Beecher 4680, Burua 4680, Calliope 4680, Glen Eden 4680, Kirkwood 4680, Oconnell 4680, Wurdong Heights 4680.

The issue stemmed from Local Power Failure, impacting approximately 6430 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 19/08/2025 11:19 AM
Last update: 19/08/2025 01:41 PM
Next update: UNKNOWN
Issue restore time: UNKNOWN

Created
Aug 25 at 11:12am AEST

We are currently experiencing a significant local network outage affecting 4G in the following localities: Beecher 4680, Burua 4680, Calliope 4680, Glen Eden 4680, Kirkwood 4680, Oconnell 4680, Wurdong Heights 4680.

The issue stemmed from Local Power Failure, impacting approximately 6430 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 19/08/2025 11:19 AM
Last update: 19/08/2025 01:41 PM
Next update: UNKNOWN
Issue restore time: UNKNOWN