Back to overview
Degraded

Unplanned 4G service outage in localised area.

Aug 25 at 11:12am AEST
Affected services
Network Stability

Updated
Aug 26 at 03:26pm AEST

We are continuing to experience a significant local network outage affecting 4G in the following localities: Crediton 4757, Owens Creek 4741.

The issue stemmed from Telstra Network (Hardware/Software/Config), impacting approximately 1419 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 19/08/2025 08:49 AM
Last update: 19/08/2025 08:58 AM
Next update: UNKNOWN
Issue restore time: 20/08/2025 06:00 PM

Created
Aug 25 at 11:12am AEST

We are currently experiencing a significant local network outage affecting 4G in the following localities: Crediton 4757, Owens Creek 4741.

The issue stemmed from Telstra Network (Hardware/Software/Config), impacting approximately 1419 services. Our response team is working with Telstra Wholesale to restore services as soon as possible. We apologise for any inconvenience caused.

EVENT DETAILS

Outage status: IN PROGRESS
Date & time of issue: 19/08/2025 08:49 AM
Last update: 19/08/2025 08:58 AM
Next update: UNKNOWN
Issue restore time: 20/08/2025 06:00 PM